Java编程工具(四):IDEA自动重置LanguageLevel和JavaCompiler版本的问题

x33g5p2x  于12个月前 转载在 Java  
字(0.3k)|赞(0)|评价(0)|浏览(80)

1、LanguageLevel和JavaCompiler

使用IDEA时,导入的Maven项目默认的LanguageLevel和JavaCompiler都是1.5,1.5的情况下连最简单的@Override注解都不支持,所以项目可能出现一堆错。

虽然在项目上可以修改LanguageLevel,在settings中可以修改JavaCompiler版本,但是一旦Maven项目有变化,发生自动的update时,这里做的修改就都白费了。IDEA会重置这些配置。

2、方法

在pom.xml中指定maven-compiler-plugin的版本,该版本会同时影响LanguageLevel和JavaCompiler,修改后默认就成了这里设置的版本。

添加下面的配置: 


这里设置的1.8,根据个人需要修改即可。

相关文章

热门文章

更多