HCIE必经之路(五)——OSPF综合实验(STUB及NSSA)

x33g5p2x  于11个月前 转载在 其他  
字(7.8k)|赞(0)|评价(0)|浏览(82)

HCIE必经之路

  • 📻实验拓扑
  • 📠实验配置
  • 📢实验讲解

📻实验拓扑

📠实验配置

OSFP综合实验

Connected to 10.0.0.1 ...
********************************************************************************
*  Copyright(c) 1998-2006 Huawei Technologies Co., Ltd.  All rights reserved.  *
*  Without the owner's prior written consent,                                  *
*  no decompiling or reverse-engineering shall be allowed.                     *
********************************************************************************

Login authentication

Username:admin
Password:
<R1>disp cu
#
 sysname R1
#
 clock summer-time 1 repeating 11:00:00 11/06/2007 11:00:00 11/09/2007  11:00:00
#
 clock timezone 1 add 11:02:02
#
 router id 1.1.1.1
#
radius scheme system
#
domain system
#
local-user admin
 password cipher .]@USE=B,53Q=^Q`MAF4<1!!
 service-type telnet terminal
 level 3
 service-type ftp
#
interface Aux0
 async mode flow
#
interface Ethernet0/0
 ip address 10.0.0.1 255.255.255.252
#
interface Ethernet0/1
 ip address 192.168.2.1 255.255.255.0
#
interface Serial0/0
 clock DTECLK1
 link-protocol ppp
 ip address 10.0.0.13 255.255.255.252
#
interface NULL0
#
ospf 1
 import-route direct
 area 0.0.0.1
  network 10.0.0.0 0.0.0.3
  vlink-peer 2.2.2.2
 #
 area 0.0.0.0
  network 10.0.0.12 0.0.0.3
#
 FTP server enable
#
user-interface con 0
user-interface aux 0
user-interface vty 0 4
 authentication-mode scheme
#
return
<R1>telnet 10.0.0.2
Trying 10.0.0.2 ...
Press CTRL+K to abort
Connected to 10.0.0.2 ...
********************************************************************************
*  Copyright(c) 1998-2006 Huawei Technologies Co., Ltd.  All rights reserved.  *
*  Without the owner's prior written consent,                                  *
*  no decompiling or reverse-engineering shall be allowed.                     *
********************************************************************************

Login authentication

Username:admin
Password:
<R2>disp cu
#
 sysname R2
#
 clock timezone GMT+8:00 minus 10:51:00
#
 cpu-usage cycle 1min
#
 router id 2.2.2.2
#
 undo connection-limit enable
 connection-limit default deny
 connection-limit default amount upper-limit 50 lower-limit 20
#
 fr switching
#
 web set-package force flash:/http.zip
#
radius scheme system
#
domain system
#
local-user admin
 password cipher .]@USE=B,53Q=^Q`MAF4<1!!
 service-type telnet terminal
 level 3
 service-type ftp
#
interface Aux0
 async mode flow
#
interface Ethernet0/0
 ip address 10.0.0.2 255.255.255.252
#
interface Ethernet0/1
 ip address 10.0.0.5 255.255.255.252
#
interface Serial0/0
 link-protocol fr
 fr interface-type dce
 fr dlci 100
 ip address 10.0.0.9 255.255.255.252
 ospf network-type nbma
#
interface NULL0
#
ospf 1
 import-route static
 peer 10.0.0.10
 area 0.0.0.1
  network 10.0.0.0 0.0.0.3
  vlink-peer 1.1.1.1
 #
 area 0.0.0.3
  network 10.0.0.4 0.0.0.3
  abr-summary 172.16.0.0 255.255.0.0 advertise
 #
 area 0.0.0.4
  network 10.0.0.8 0.0.0.3
  stub no-summary
#
 FTP server enable
#
 ip route-static 100.100.100.0 255.255.255.0 10.0.0.1 preference 60
#
user-interface con 0
user-interface aux 0
user-interface vty 0 4
 authentication-mode scheme
#
return
<R2> telnet 10.0.0.6
Trying 10.0.0.6 ...
Press CTRL+K to abort
Connected to 10.0.0.6 ...
********************************************************************************
*  Copyright(c) 1998-2006 Huawei Technologies Co., Ltd.  All rights reserved.  *
*  Without the owner's prior written consent,                                  *
*  no decompiling or reverse-engineering shall be allowed.                     *
********************************************************************************

Login authentication

Username:admin
Password:
<R3>disp cu
#
 sysname R3
#
 router id 3.3.3.3
#
radius scheme system
#
domain system
#
local-user admin
 password cipher .]@USE=B,53Q=^Q`MAF4<1!!
 service-type telnet terminal
 level 3
 service-type ftp
#
interface Aux0
 async mode flow
#
interface Ethernet0/0
 ip address 192.168.3.1 255.255.255.0
#
interface Ethernet0/1
 ip address 10.0.0.6 255.255.255.252
#
interface Serial0/0
 clock DTECLK1
 link-protocol ppp
 ip address dhcp-alloc
#
interface NULL0
#
interface LoopBack0
 ip address 172.16.1.1 255.255.255.0
#
interface LoopBack1
 ip address 172.16.2.1 255.255.255.0
#
interface LoopBack2
 ip address 172.16.3.1 255.255.255.0
#
ospf 1
 area 0.0.0.3
  network 10.0.0.4 0.0.0.3
  network 172.16.1.0 0.0.0.255
  network 172.16.2.0 0.0.0.255
  network 172.16.3.0 0.0.0.255
#
 FTP server enable
#
user-interface con 0
user-interface aux 0
user-interface vty 0 4
 authentication-mode scheme
#
return
<R3>telnet 10.0.0.10
Trying 10.0.0.10 ...
Press CTRL+K to abort
Connected to 10.0.0.10 ...
********************************************************************************
*  Copyright (c) 1998-2007 Huawei Technologies Co., Ltd.  All rights reserved. *
*  Without the owner's prior written consent,                                  *
*  no decompiling or reverse-engineering shall be allowed.                     *
********************************************************************************

Login authentication

Username:admin
Password:
<Router-4>disp cu
#
 sysname Router-4
#
 cpu-usage cycle 1min
#
 router id 4.4.4.4
#
 web set-package force flash:/http.zip
#
radius scheme system
#
domain system
#
local-user admin
 password cipher .]@USE=B,53Q=^Q`MAF4<1!!
 service-type telnet terminal
 level 3
 service-type ftp
#
interface Aux0
 async mode flow
#
interface Ethernet0/0
 loopback
 ip address 192.168.4.1 255.255.255.0
#
interface Ethernet0/1
 ip address dhcp-alloc
#
interface Serial0/0
 clock DTECLK1
 link-protocol fr
 fr map ip 10.0.0.9 100
 ip address 10.0.0.10 255.255.255.252
 ospf network-type nbma
#
interface Serial1/0
 clock DTECLK1
 link-protocol ppp
 ip address dhcp-alloc
#
interface Serial1/1
 clock DTECLK1
 link-protocol ppp
 ip address dhcp-alloc
#
interface NULL0
#
interface LoopBack0
 ip address 4.4.4.4 255.255.255.255
#
ospf 1
 peer 10.0.0.9
 area 0.0.0.4
  network 10.0.0.8 0.0.0.3
  network 192.168.4.0 0.0.0.255
  stub
#
 FTP server enable
#
user-interface con 0
user-interface aux 0
user-interface vty 0 4
 authentication-mode scheme
#
return
<Router-4> 

[R6]
[R6]
[R6]disp cu
#
 sysname R6
#
 clock timezone 1 minus 15:02:00
#
 router id 6.6.6.6
#
radius scheme system
#
domain system
#
local-user admin
 password cipher .]@USE=B,53Q=^Q`MAF4<1!!
 service-type telnet terminal
 level 3
 service-type ftp
#
interface Aux0
 async mode flow
#
interface Ethernet0/0
 loopback
 ip address 192.168.5.1 255.255.255.0
#
interface Ethernet0/1                     
 ip address dhcp-alloc
#
interface Serial0/0
 link-protocol ppp
 ip address 10.0.0.14 255.255.255.252
#
interface Serial1/0
 clock DTECLK1
 link-protocol ppp
 ip address dhcp-alloc
#
interface Serial1/1
 clock DTECLK1
 link-protocol ppp
 ip address dhcp-alloc
#
interface NULL0
#
ospf 1
 area 0.0.0.5
  network 192.168.5.0 0.0.0.255
 #
 area 0.0.0.0
  network 10.0.0.12 0.0.0.3               
#
 FTP server enable
#
user-interface con 0
user-interface aux 0
user-interface vty 0 4
 authentication-mode scheme
#
return
[R6]

关于STUB、NSSA区域的深度解析

NSSA:
1.不加NO SUM,显示外部路由、AS内路由和默认路由
2.加NO SUM,将会只会显示外部路由和默认路由

STUB:
1.不加NO SUM,显示AS内路由和默认路由
2.加NO SUM,将会只会显示默认路由

NSSA

0.0.0.0/0          O_NSSA   150  1           10.0.0.9        Serial0/0
4.4.4.4/32         DIRECT   0    0           127.0.0.1       InLoopBack0
10.0.0.0/30        OSPF     10   1563        10.0.0.9        Serial0/0
10.0.0.4/30        OSPF     10   1563        10.0.0.9        Serial0/0
10.0.0.8/30        DIRECT   0    0           10.0.0.10       Serial0/0
10.0.0.9/32        DIRECT   0    0           10.0.0.9        Serial0/0
10.0.0.10/32       DIRECT   0    0           127.0.0.1       InLoopBack0
10.0.0.12/30       OSPF     10   3125        10.0.0.9        Serial0/0
100.100.100.0/24   O_NSSA   150  1           10.0.0.9        Serial0/0
127.0.0.0/8        DIRECT   0    0           127.0.0.1       InLoopBack0
127.0.0.1/32       DIRECT   0    0           127.0.0.1       InLoopBack0
172.16.0.0/16      OSPF     10   1564        10.0.0.9        Serial0/0
192.168.4.0/24     DIRECT   0    0           192.168.4.1     Ethernet0/0
192.168.4.1/32     DIRECT   0    0           127.0.0.1       InLoopBack0

NSSA-no sum

0.0.0.0/0          OSPF     10   1563        10.0.0.9        Serial0/0
4.4.4.4/32         DIRECT   0    0           127.0.0.1       InLoopBack0
10.0.0.8/30        DIRECT   0    0           10.0.0.10       Serial0/0
10.0.0.9/32        DIRECT   0    0           10.0.0.9        Serial0/0
10.0.0.10/32       DIRECT   0    0           127.0.0.1       InLoopBack0
100.100.100.0/24   O_NSSA   150  1           10.0.0.9        Serial0/0
127.0.0.0/8        DIRECT   0    0           127.0.0.1       InLoopBack0
127.0.0.1/32       DIRECT   0    0           127.0.0.1       InLoopBack0
192.168.4.0/24     DIRECT   0    0           192.168.4.1     Ethernet0/0
192.168.4.1/32     DIRECT   0    0           127.0.0.1       InLoopBack0

STUB

0.0.0.0/0          OSPF     10   1563        10.0.0.9        Serial0/0
4.4.4.4/32         DIRECT   0    0           127.0.0.1       InLoopBack0
10.0.0.0/30        OSPF     10   1563        10.0.0.9        Serial0/0
10.0.0.4/30        OSPF     10   1563        10.0.0.9        Serial0/0
10.0.0.8/30        DIRECT   0    0           10.0.0.10       Serial0/0
10.0.0.9/32        DIRECT   0    0           10.0.0.9        Serial0/0
10.0.0.10/32       DIRECT   0    0           127.0.0.1       InLoopBack0
10.0.0.12/30       OSPF     10   3125        10.0.0.9        Serial0/0
127.0.0.0/8        DIRECT   0    0           127.0.0.1       InLoopBack0
127.0.0.1/32       DIRECT   0    0           127.0.0.1       InLoopBack0
172.16.0.0/16      OSPF     10   1564        10.0.0.9        Serial0/0
192.168.4.0/24     DIRECT   0    0           192.168.4.1     Ethernet0/0
192.168.4.1/32     DIRECT   0    0           127.0.0.1       InLoopBack0

STUB-NO SUM

0.0.0.0/0          OSPF     10   1563        10.0.0.9        Serial0/0
4.4.4.4/32         DIRECT   0    0           127.0.0.1       InLoopBack0
10.0.0.8/30        DIRECT   0    0           10.0.0.10       Serial0/0
10.0.0.9/32        DIRECT   0    0           10.0.0.9        Serial0/0
10.0.0.10/32       DIRECT   0    0           127.0.0.1       InLoopBack0
127.0.0.0/8        DIRECT   0    0           127.0.0.1       InLoopBack0
127.0.0.1/32       DIRECT   0    0           127.0.0.1       InLoopBack0
192.168.4.0/24     DIRECT   0    0           192.168.4.1     Ethernet0/0
192.168.4.1/32     DIRECT   0    0           127.0.0.1       InLoopBack0

相关文章